Go
New
Find
Notify
Tools
Reply
  
Firmware update failed, CP540 can t power on
 Login/Join
 
Junior Member
posted
Hello,
After failed my firmware update (download can t finish, try again or like this error)
and try and try again, my CP540 doesn t power on.

Anyone have an idea or where can i send it for repair?

Many thanks
 
Posts: 2 | Registered: June 28, 2014Report This Post
Member
posted Hide Post
Have you tried to reset the 540? With the unit turned off. Open the Battery cover and take a paper clip. There is a small hole above the batteries with the reset button. press the paper clip into the hole and press for a couple seconds. Try to turn unit on. See if that helps.
 
Posts: 31 | Location: Ludlow, Vermont, USA | Registered: October 24, 2002Report This Post
Junior Member
posted Hide Post
Many thanks but already do this, removing battery and reset more and more time, but doesnt power on.

Another idéa?
 
Posts: 2 | Registered: June 28, 2014Report This Post
Member
posted Hide Post
Have you tried to re flash the memory again? It would seem that the issue started with that failed attempt.

Sending the unit back to TAG Heuer in Switzerland is the safest thing to do if you get frustrated.
 
Posts: 13 | Registered: July 31, 2012Report This Post
Member
posted Hide Post
You can make a factory reset.
turn off the unit, remove the batteries, disconnect the charger.
Pull the rubber cover, connect two pins (such as a screwdriver or paper clip) NOTE: ONLY THESE TWO PINS!
work?
 
Posts: 5 | Registered: November 08, 2011Report This Post
  Powered by Social Strata  
 


© 2000-2014 Phoenix Sports Technology. Administration by www.alphasports.tv